/ April 12, 2010/ Blog

Für Joomla 1.5.9

Wenn man im Content Links zu anderen Beiträgen anlegt und anschliesend SEO in der Konfiguration anschaltet, funktionieren einige Links nicht mehr.

Das Geheimnis ist, dass Links die auf andere Templates verweisen, nicht funktionieren.

 

Es gibt folgende Möglichkeiten:

im Link den fetten Bereich wegnehmen,

index.php?option=com_content&view=article&id=45&Itemid=79

index.php?option=com_content&view=article&id=45

dann wird man aber im selben Template bleiben.

Oder man nimmt die SEO Urls:

de/gemeinsam-schaffen-wir-das.html

Diese sind leider aber nur durch try and find herauszufinden, indem man z.B. in der Blogansicht der Artikel die Links kopiert.

 

Wenn man diesen wieder ein anderes Template zuweisen möchte, muss man

  1. ein Menü anlegen (dieses Menü muss nicht auf der Frontpage zu sehen sein, aber es muss existieren)
  2. einen Menüpunkt mit der Blogansicht anlegen mit den gewünschten Artikeln. Dieser Menüpunkt muss freigegeben sein.
  3. in der Templatezuweisung erhält dieser Menüpunkt das gewünschte Template.
  4. im Menüpunkt siehst du eine Url, diese verwendest du um in die Blogansicht zu kommen.
  5. Dort sind jetzt die weiterlesen Links – und zwar als seo oder nicht, je nach Einstellung in der Konfiguration.

Wenn du nun diese Links verwendest in deinem Content, wirst du in den Artikel im gewünschten Template sehen.

 

Du siehst keine Weiterlesenlinks?

Dann kannst du unter den Einstellungen beim Menüpunkt und ggf. des Beitrags: Verlinkten Seitentitel anzeigen aktivieren. Wenn du in den Einstellungen der Artikel diese Option ausgeschaltet hast, wird sie nur in diesem Menüpunkt aktiv sein, und deinen Productionmode nicht stören.